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Abstract 

It is made a review of the classical techniques and devices used for mapping underground galleries and natural caves. 

A new method is proposed and realized by the means of modern technologies in the Pepelyankata cave nearby the 

village of Bosnek, Pernik Province. 

A GPS receiver is used to determine the coordinates of the starting point. Another device - a combination between a 

laser rangefinder, a compass and an inclinometer, is used to measure the traverse and certain points inside the cave. 

All of the measurements are transferred wirelessly to a PDA device and represented by a suitable mobile GIS-enabled 

software. Some other data, including photos made by the PDA’s integrated camera, is collected as an additional 

attribute information.  

Back in the office, the results are superposed on an old map of the cave, an orthophoto image and topographic map of 

the region for further analysis. 

 

1. INTRODUCTION 

 
Nowadays, caves are considered to be among the last geographic frontiers on Earth. As they provide a first-hand view 

of the subsurface, rock structure and underground water as well as biology, oil and mineral distribution, their value is 

getting more and more appreciated. However, no matter what studies are to be done or problems to be solved, all of 

them are referenced to certain locations and exact points in a cave. The ultimate goal is a three-dimensional map that 

shows the cave layout to help in understanding the cave and lead to further studies and to target promising areas for 

advanced exploration (Palmer, 2007). 

The basic stages of mapping a cave are collecting the data, managing it and drafting the map (Dasher, 1994). 

 

2. CLASSICAL METHODS AND DEVICES IN CAVE MAPPING 

 
A typical cave survey is divided into several jobs – locating and marking the survey stations, lighting the target points, 

holding and reading the instruments, notekeeping, sketching, often in a combination with exploration, checking mazy 

and side passages, and overall coordination and leadership. Usually these responsibilities are handled by two to five 

people. 

Choosing surveying instruments depend on different criteria – ruggedness, accuracy, cost, transportation size, ease of 

learning, ease of using and includes compass and/or clinometer.  The compass-tape-inclinometer method is a classical 

technique, widely used even nowadays for its ruggedness, sufficient accuracy, low cost, compactness and so on. In 

comparison, theodolite survey is extremely accurate, however it is quite fragile, large and expensive. It is much the 

same with 3D laser scanners which offer a complete and accurate gallery modeling at the expense of their large 

transportation size, fragility and high cost. In terms of the final target – a cave map, different means are classified in an 

official grading system (Table 1).  

Table 1. UIS Mapping Grades 

Grade Description Precision 

length, [m] 

Compass, 

[
o
] 

Clino, 

[
o
] 

Expected 

accuracy, [%] 

-1 No map available - - - - 
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0 Ungraded - - - - 

1 Sketch from memory, not to scale - - - - 

2 Map compiled from annotations, sketches and 

estimates made in the cave. No instruments used. 

- - - - 

3 Directions measured by compass, distances 

measured by cord, pace or body dimensions. 

Significant slopes estimated. 

0.5 5 - 10 

4 Compass and tape survey, using deliberately 

chosen and fixed situations. Slopes measured by 

clinometer or horizontal and vertical components 

of line. 

0.1 2 2 5 

5 Compass and tape survey. Directions and slope by 

calibrated instruments, distances, by fiberglass or 

metallic tape, or tacheometry. 

0.05 1 1 2 

6 Survey or triangulation using calibrated, tripod-

mounted instruments for directions and slope. 

Distances by calibrated tape, precise tacheometry, 

or calibrated DistoX type 

0.02 0.25 0.25 1 

X Survey by theodolite or comparable means variable   variable 

 

3. EXPLORING AND SURVEYING PEPELYANKATA CAVE. 

 

3.1. Choosing instruments. 

 
Pepelyankata is a natural dry cave nearby the village of Bosnek, Pernik Province. As limestone is the host rock in the 

region, there are many other cave formations nearby, including the longest cave system in Bulgaria – Duhlata.  

For the aim of this study there are prepared two GNSS handhelds and a laser rangefinder: 

 Trimble
®
 GeoExplorer

®
 3000 GeoXH™ – a GPS-enabled mobile device that supports postprocessed 

positioning accuracy up to 1 cm. It is used at the cave entrance to coordinate the starting point of the whole survey. 

 Trimble Juno™ SC – one more GPS enabled PDA (Personal Digital Assistant) device which, however, because 

of its compactness is used to store and manage measurements inside the cave. Its features – 3.5” touch screen, 533 MHz 

processor, 128 MB RAM, 128 MB flash data storage, internal all-day battery (2600 mAh) and lightweight (240 g) and 

small size (12.9 cm x 7.4 cm x 3.0 cm), as well, is suitable for the task. 

  Trimble LaserAce™ 1000 – the device with the most important role in this survey as a combination of laser 

rangefinder, compass and inclinometer. Its technical specifications – up to 150 m passive range of laser and accuracy of 

10 cm, compass accuracy of 2
o
 and inclinometer accuracy of 0.2

o
, are comparable to current widely used surveying 

instruments, however its lightweight (464 g) and 3-in-one compactness appears to be much more attractive. Dust proof 

and water resistant casing (IP63) are suitable enough for the harsh conditions inside Pepelyankata. Although it provides 

powerful standalone measurements previewed on its backlit LCD display, in this case it is combined with the Juno 

handheld connected via Bluetooth. 

As these devices allow collecting data in the harsh environment of a cave, the right software enables the task to be 

completed in a fast and efficient way. That is why the solution is completed with a suitable GIS-enabled software for 

the Juno handheld: 

 DigiTerra Explorer™ (DTE) 6 Professional – compared to the other two, lower versions – Basic and Advanced, 

version Professional supports the full mobile and desktop GIS and GPS functionality of DTE software. As it allows 

using map backgrounds, displaying and editing data in a wide range of vector and raster formats, integration with 

external sensors (like laser range finders), built-in cameras, topological, preview and editing tools., it is the right choice 

for the task. In addition, the software supports different coordinate systems and projections, including the Bulgarian 

UTM Zone 35 N, WGS 84. Offering a native support for mobile computers (Windows
®
 Mobile/CE OS's) and for 

desktop computers (Windows
®
 2000, XP, Vista, 7), DTE is a plug-and-play software and so doesn’t require any 

installation. It is distributed on a SD/miniSD card which is put in the slot of Juno. It supports a variety of languages 

including Bulgarian, English, French, German, Italian, etc. 



3.2. Collecting the data. 

 
The work inside the cave was divided between three people – an experienced caver to lead the team throughout the cave 

and to point out its special characteristics that must be surveyed in order to get a complete cave layout, and two 

surveyors to operate with the Juno handheld and LaserAce. At the very beginning, at the cave entrance outside the cave, 

it is coordinated the starting point of the whole survey. The achieved accuracy by GeoXH after 20 minutes at the point 

was 7 cm. Inside the cave measurements are organized as a standart mine traverse using LaserAce.  

Survey stations are chosen due to line-of-sight and any special features and then marked with small rocks or natural 

formations. Once foresight stations are marked, measurements are done by one person himself, lighting target points 

and reading and verifying records. Мeasured distances, azimuth and inclination angles are transmitted directly to the 

Juno handheld via Bluetooth where the new measured points are previewed and recorded (Figure 1). Paperless 

sketching and notekeeping are also done on the handheld. 

 

 

In advance, it has been created an attribute table in DTE so that point coordinates are not the only recorded information. 

The table is filled with the exact measured values – angles and distances, photo captures and additional notes (Figure 3). 

The software allows adding new attributes and editing old whenever needed (Figure 2). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

Figure 1. a) Collecting the data with b) LaserAce 1000 rangefinder and c) Juno handheld. 

a) 

b) 

c) 

Figure 2. Creating new data field Figure 3. Cave surveying attribute table of DTE 



The whole process of exploring the cave and collecting the data is completed within two days – the first one mapping 

upstairs, and the second day downstairs. 

 

 

3.3. Managing the data. 

 

DTE workspace contains a variety of tools for 

data import/export (the File menu bar, Figure 

4), sketching (the Edit menu bar), data 

preview (the View menu bar), feature 

information (the Query menu bar), GPS 

functionality (the GPS menu bar) and 

different tools for raster orientation, survey 

settings, polygon modification  (the Tools 

menu bar), etc. The workspace frame consists 

of shortcut buttons for the layers list, attribute 

table, GPS, faster preview and easy map 

navigation on the map screen. 

All stations and measured points are 

previewed real-time in the DTE workspace, 

organized in different layers according to 

their type - point, line, polygon. Measured 

points are recorded in a point layer, and cave 

sides and the traverse line – in a line layer 

(Figure 5Error! Reference source not 

found.). Data is labeled due to its layer and 

corresponding attribute information (Error! 

Reference source not found.). By selecting a 

feature its attribute table is easily previewed. 

 

            
 

 

  

  

The Layer dialog box is where a list of all the loaded layers is shown (Figure 7). It is used to manage the layers in the 

map and set various layer properties. In this dialog box layers can be added, edited, reordered, turned or on off, saved, 

a) b) 

The Tools menu bar 

The GPS menu bar 

The File menu bar 

The Edit menu bar 

The View menu bar 

The Query menu bar 

Figure 4. DTE mobile workspace, shortcut buttons frame and menu bars 

Figure 5. Map Window of DTE: a) The line layer, including both measured upstairs cave sides (labeled as Left and 

Right) and traverse line (Centre); b) Both line and point layers, measured side points and stations are labeled with 

their IDs. 



removed. The Scale, Source, Classes and Labels are additional dialog boxes that can be opened to view and change 

properties of the selected layer. 

Feature labels and symbols can be turned off or displaying feature’s information of up to 3 chosen fields from the 

corresponding attribute table (Figure 6). Their visibility also can be limited by defined scale value. As labels are usually 

an important part of map contents, DTE supports different fonts, text sizes, bold, italic, underline and other designing 

tools. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.4. Drafting the map. 

 
Quick and structured data is achieved still inside the cave due to the mobile GIS-enabled solution. As the task is basic 

surveying no special symbols are used, although DTE supports a variety of markers and possibilities to load new sets 

(Figure 8). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 8. DTE supports a variety of a) Point symbols and b)Linetypes. 

a) b) 

Figure 6. Feature labels can be formatted in 

many different ways 
Figure 7. Layer dialog box 



The measurements are saved as a DTE map file in a user defined 

directory. Back in the office the results are previewed with the desktop 

version of DTE. DTE desktop screen and tools are much similar to 

those in the mobile version, except the difference in their positions, also 

the full path of the open project and coordinates of the current cursor 

position shown in DTE desktop. 

Both mobile and desktop DTE Professional support a variety of vector, 

raster and table file formats to import as layers: 

- Vector: BNA, CRD, DAT, DGN, DXF, LOG, MAP, 

MIF/MID, SHP; 

- Raster: BIL, BMP, ECW, ERS, JPG, JP2, LAN, PCX, RAS, 

SID, TIF; 

- Table: DBF, MDT, TAB, TXT. 

For further analysis the cave map could be superposed on an aerial 

orthophoto image, topographic map, old cave map, etc., in order to 

show its relation to the surrounding landscape, local geology, regional 

drainage and so on (Palmer, 2007). A raster layer could be modified by 

its brightness and contrast features, and setting a certain colour or the 

entire layer transparent as well (Figure 9). 

On Figure 10 it is shown the map drafted inside the cave and a topographic map (.jpg) and an orthophoto image (.tif) 

loaded as background layers. Eventhough they have been georeferenced in advance, it is also possible to be done by 

DTE. A full list of loaded layers can be seen on the left part of the screen, where they can be inserted, selected, labeled, 

edited, reordered, turned off, deleted.  

 
 

 

 

4. KEY FEATURES AND BENEFITS. 

 
After all data is collected, managed and the cave map iss drafted, objectively, there could be drawn the present benefits 

of the proposed method of cave mapping and supposed future opportunities: 

 The LaserAce 1000 rangefinder: could be used as a standalone 3-in-1 solution compared to tape/rangefinders, 

compass and inclinometer. No need of preventing tape kinks or cleaning of mud to read. Just one person is needed to 

operate with LaserAce in comparison to the classical techniques. Its point-and-shoot simplicity allows capturing a point 

with one single shot and immediate visualization of the measured data; 

Figure 10. DTE desktop screen 

Figure 9. Raster options 



 The Juno handheld: excludes the need of paper and pencils for sketching and notekeeping, and more people for 

these activities. This also means not only less tools to bring, but no problems with their damages or lost inside the cave, 

and their further storage. The amount of recorded data depends on the Juno’s flash memory and SD card expansion 

which compared to the classical tools are practically inexhaustible; 

 DTE: its support of external sensors allows using rangefinders, cameras and many more devices to collect a 

wide variety of information. The range of supported file formats allows loading additional vector, raster and table data 

for further analysis, field navigation, new explorations, etc., file exporting for easy integration with other software 

applications and GIS databases. 

 LaserAce 1000, Juno and DTE: the seamless combination between LaserAce and Juno via Bluetooth allows 

measurements and their consistency to be easily checked. The solution gives the confidence of a fully automated 

calculation process which protects from any personal mistakes when coordinating measured points. Collecting spatial 

3D data makes possible both plan and profile view to be drawn wherever needed. All data can be easily updated later, 

including new features and additional attribute information. It is a compact, lightweight and rugged GIS-enabled 

solution for easy and quick work done still inside the cave. Mapping could be done even by one single person. 

 

5. CONCLUSION. 

 
The proposed method, including handheld devices, a rangefinder and software with GIS functionality, provides a 

powerful modern tool for spatial data collection in harsh environments. Compared to the UIS Grading System, classical 

and modern surveying methods, the proposed one is the optimal solution that allows cave mapping in a reliable, quick 

and easy way. 
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